La version 3.0.1 n'est pas fiable

Pour toutes les questions sur les produits TI-Nspire et leur utilisation

La version 3.0.1 n'est pas fiable

Messagepar Invité le 19 Avr 2011, 22:47

--------------

:!: EDIT : UN CORRECTIF POUR LA VERSION 3.0.1 EST ATTENDU D'ICI MI-MAI
Voir : http://www.univers-ti-nspire.fr/forum/viewtopic.php?f=6&t=526

--------------

Tout est dans le titre...
La version 3.0.1 n'est pas fiable pour les examens et concours

Après le problème rencontré avec la fonction czeros et ses conséquences sur l'utilisation de la bibliothèque d'algèbre linéaire, un nouveau bug vient d'être mis en évidence (par le site ti-bank) avec l'utilisation de la fonction de résolution des équations différentielles.

L'exemple donné sur ti-bank fait appel à des coefficients décimaux, mais ce bug se produit aussi avec des coefficients "simples".

Par exemple, la résolution de l'équation différentielle
-y'(x)+y(x)=0 avec la condition initiale y(0)=1,
ce qui s'écrit :
desolve(-y'+y=0 and y(0)=1,x,y)
suffit à provoquer une erreur.

On pourra noter que
desolve(y'+y=0 and y(0)=1,x,y)
ou encore
desolve(y'-y=0 and y(0)=1,x,y)
ne posent aucun problème !

Par contre,
deSolve(y'/2+y=0 and y(0)=1,x,y)
provoque une erreur...

Les exemples ci-dessus concernent le cours de terminale S (et donc potentiellement l'utilisation au bac), mais naturellement, le problème concerne aussi les équations linéaires d'ordre 2 très utilisées en prépa, comme par exemple :
deSolve(y''/2-y'+y=0 and y(0)=1 and y'(0)=−1,x,y)

Toutes ces instructions fonctionnent correctement sur la version 2.1.

J'espère que nous aurons très vite une réponse appropriée de Texas Instruments à ce problème.
Un bug est toujours possible... Mais la principale difficulté réside dans le fait que les personnes qui ont mis à jour vers la version 3.0 ne peuvent plus revenir en arrière et revenir à l'utilisation d'une version précédente ne comportant pas cette erreur.
(du moins sans recourir à des moyens qui ne sont pas vraiment à la portée de tous...)

En attendant, la solution consiste à ne surtout pas accepter la mise à jour qui est proposée, et à rester avec la version 2.
Dernière édition par Invité le 25 Avr 2011, 20:00, édité 6 fois au total.
Invité
 

Re: La version 3.0.1 n'est pas fiable

Messagepar Invité le 19 Avr 2011, 23:41

Une précision suite à la lecture du forum de ti-bank :
1/ TI vient d'être averti (directement, au niveau de l'équipe de développement) de ce problème.
2/ Le ton de certains messages est difficile à comprendre...
Il y a un problème sérieux, mais il me semble raisonnable d'attendre de voir quelle sera la réaction de TI avant d'exprimer des jugements "aussi définitifs"...
Pour ma part, j'espère que cette réaction sera rapide.
Invité
 

Re: La version 3.0.1 n'est pas fiable

Messagepar critor le 19 Avr 2011, 23:45

Merci pf pour votre réaction aussi rapide, ainsi que vos nouveaux exemples.

J'espère aussi qu'il y aura une correction rapidement, surtout pour les élèves/étudiants qui ont des échéances très bientôt.


En ce qui me concerne, je comprends parfaitement que l'OS Nspire est très complexe avec des tâches à partager entre différentes équipes ou sous-équipes. En cela, je n'ai rien à dire car je serai évidemment incapable de faire mieux.

Mon ton aurait sûrement été bien plus doux si il avait toujours été possible de "revenir en arrière", et si l'OS 3.0 ne continuait pas en ce moment même d'être proposé par les fenêtres de mise à jour automatiques partout dans le monde.


Je vous prie de m'excuser si je vous ai choqué. Bien cordialement, et en vous remerciant encore pour votre réactivité.
Visitez le nouveau site calculatrices TI francophone: TI-Planet

Quelques-un de mes programmes Nspire:
* Table interactive des radionucléides (Lua)
* Dérivées pas à pas (Basic)
* Lecteur d'images (Ndless)
* Calcul exact (Basic)
critor
 
Messages: 308
Inscrit le: 18 Nov 2009, 22:28

Re: La version 3.0.1 n'est pas fiable

Messagepar Christian le 20 Avr 2011, 01:28

Bonjour,
Il semble que la solution générale de l'équation différentielle soit parfaitement donnée, même dans les cas qui posent problème... mais pas la solution en imposant une condition initiale.
C'est effectivement très gênant et il est préférable que les utilisateurs de la nouvelle version soit au courant de ce sérieux problème.
Je suis d'accord avec pf: attendons la réaction de TI, puisqu'ils sont prévenus, avant de crier haro sur le baudet.
Bien cordialement,
Christian
Avatar de l’utilisateur
Christian
 
Messages: 340
Inscrit le: 22 Août 2008, 13:42

Re: La version 3.0.1 n'est pas fiable

Messagepar Levak92 le 20 Avr 2011, 01:32

Et encore un bug :
http://ti.bank.free.fr/index.php?mod=ne ... es&id=1057

Et celui là est méchant. Peut être pas d'update possible pour les nouvelles CX, histoire de bien enfoncer le clou \o/
Levak92
 
Messages: 321
Inscrit le: 02 Juin 2010, 23:03
Localisation: France

Re: La version 3.0.1 n'est pas fiable

Messagepar Invité le 20 Avr 2011, 09:25

TI France m'a envoyé un message ce matin, confirmant leur intervention auprès de l'équipe de développement (Dallas) pour obtenir une résolution rapide de ce problème.
Invité
 

Re: La version 3.0.1 n'est pas fiable

Messagepar Invité le 20 Avr 2011, 11:35

Christian a écrit:Bonjour,
Il semble que la solution générale de l'équation différentielle soit parfaitement donnée, même dans les cas qui posent problème... mais pas la solution en imposant une condition initiale.


Juste un hypothèse : la résolution (via desolve ) de l'équation générale d'une équation différentielle linéaire d'ordre 1 avec condition initiale se fait peut-être en résolvant d'abord l'équation différentielle sans condition initiale, puis en utilisant la fonction czeros, ou une fonction également utilisée par czeros, pour résoudre l'équation permettant de déterminer la valeur du coefficient ?
Cela expliquerait l'apparente similitude entre les deux problèmes rencontrés, et l'absence de problème lorsque l'on n'impose pas de condition initiale...
Invité
 

Re: La version 3.0.1 n'est pas fiable

Messagepar Christian le 20 Avr 2011, 12:24

BOnjour,
TOut d'abord, la résolution sans condition initiale semble fonctionner sans aucun problème.
Par ailleurs, mais je peux me tromper, on peut contourner la difficulté en résolvant l'équation par rapport à y' ou y'', comme le montre les exemples qui suivent.
Ces deux affirmations ne sont que des conjectures, merci de les infirmer si vous trouvez des contre-exemples.
Ce n'est qu'une solution provisoire bien sûr. On attend impatiemment que TI règle ces problèmes.
Bien cordialement,
Christian
image10.jpg
image10.jpg (60.62 Kio) Consulté 6954 fois
Avatar de l’utilisateur
Christian
 
Messages: 340
Inscrit le: 22 Août 2008, 13:42

Re: La version 3.0.1 n'est pas fiable

Messagepar Christian le 20 Avr 2011, 12:27

Réponse à pf: ton hypothèse est parfaitement plausible. Il serait étonnant que les deux problèmes ne soient pas associés.
Le problème disparaitrait pour une ed du type y'= ou y''=... si ce que j'observe est bien général...
Bien amicalement,
Christian
Avatar de l’utilisateur
Christian
 
Messages: 340
Inscrit le: 22 Août 2008, 13:42

Re: La version 3.0.1 n'est pas fiable

Messagepar critor le 20 Avr 2011, 12:31

Je pense également que les 2 problèmes ont un dénominateur commun.

Dans les 2 cas, le moteur formel peut ramener la question à une recherche des racines réelles et complexes d'un polynome.
Visitez le nouveau site calculatrices TI francophone: TI-Planet

Quelques-un de mes programmes Nspire:
* Table interactive des radionucléides (Lua)
* Dérivées pas à pas (Basic)
* Lecteur d'images (Ndless)
* Calcul exact (Basic)
critor
 
Messages: 308
Inscrit le: 18 Nov 2009, 22:28

Suivant

Retourner vers Questions sur TI-Nspire



Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Aucun utilisateur inscrit et 1 invité

cron

© Copyright 2008 - Tous droits réservés.